]> Untitled Git - awful.systems.git/blob - hardware/hetzner-cloud/cpx31.nix
docs: add database information
[awful.systems.git] / hardware / hetzner-cloud / cpx31.nix
1 { config, lib, pkgs, modulesPath, ... }:
2
3 {
4   imports = [ (modulesPath + "/profiles/qemu-guest.nix") ../shared.nix ];
5
6   boot.initrd.availableKernelModules =
7     [ "ahci" "xhci_pci" "virtio_pci" "virtio_scsi" "sd_mod" "sr_mod" ];
8   boot.initrd.kernelModules = [ "dm-snapshot" ];
9   boot.kernelModules = [ ];
10   boot.extraModulePackages = [ ];
11   boot.loader.grub.enable = true;
12   boot.loader.grub.devices = [ "/dev/sda" ];
13
14   # boot off an LVM pool named NixOS and lv named System
15   fileSystems."/" = {
16     device = "/dev/NixOS/System";
17     fsType = "ext4";
18   };
19
20   swapDevices = [ ];
21
22   networking.useDHCP = false;
23   networking.interfaces.enp1s0.useDHCP = lib.mkDefault true; # public IP
24   networking.interfaces.enp7s0.useDHCP =
25     lib.mkDefault true; # first internal network
26
27   nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
28 }