]> Untitled Git - awful.systems.git/blob - hardware/hetzner-cloud/cx21.nix
add "more" host to awful.systems cluster
[awful.systems.git] / hardware / hetzner-cloud / cx21.nix
1 { config, lib, pkgs, modulesPath, ... }:
2
3 {
4   imports = [ (modulesPath + "/profiles/qemu-guest.nix") ../shared.nix ];
5
6   boot.initrd.availableKernelModules =
7     [ "ata_piix" "virtio_pci" "xhci_pci" "sd_mod" "sr_mod" ];
8   boot.initrd.kernelModules = [ ];
9   boot.kernelModules = [ ];
10   boot.extraModulePackages = [ ];
11   boot.loader.grub.enable = true;
12   boot.loader.grub.devices = [ "/dev/sda" ];
13
14   fileSystems."/" = { device = "/dev/sda1"; };
15
16   swapDevices = [ ];
17
18   networking.useDHCP = false;
19   networking.interfaces.ens3.useDHCP = true; # public IP
20   networking.interfaces.ens10.useDHCP = true; # first internal network
21
22   nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
23 }