]> Untitled Git - awful.systems.git/blob - hardware/hetzner-cloud.nix
Initial commit
[awful.systems.git] / hardware / hetzner-cloud.nix
1 { config, lib, pkgs, modulesPath, ... }:
2
3 {
4   imports = [ (modulesPath + "/profiles/qemu-guest.nix") ./shared.nix ];
5
6   boot.initrd.availableKernelModules =
7     [ "ata_piix" "virtio_pci" "xhci_pci" "sd_mod" "sr_mod" ];
8   boot.initrd.kernelModules = [ ];
9   boot.kernelModules = [ ];
10   boot.extraModulePackages = [ ];
11   boot.loader.grub.enable = true;
12   boot.loader.grub.devices = [ "/dev/sda" ];
13
14   fileSystems."/" = { device = "/dev/sda1"; };
15
16   swapDevices = [ ];
17
18   time.timeZone = "America/Los_Angeles";
19
20   networking.useDHCP = false;
21   networking.interfaces.ens3.useDHCP = true; # public IP
22   networking.interfaces.ens10.useDHCP = true; # first internal network
23
24   nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
25 }