]> Untitled Git - awful.systems.git/blob - hosts/these/configuration.nix
docs: add database information
[awful.systems.git] / hosts / these / configuration.nix
1 { pkgs, ... }:
2
3 {
4   imports = [
5     ../../hardware/hetzner-cloud/cx21.nix
6     ../../secrets
7     ../../pass
8     #../../lemmy/staging
9     ../../lemmy/dev
10     ../../maint-mode
11     ../../git
12     ../../sneer-archive
13   ];
14
15   networking.hostName = "these";
16
17   services.nginx = {
18     recommendedProxySettings = true;
19     recommendedTlsSettings = true;
20
21     virtualHosts = {
22       "breaking.awful.systems" = {
23         forceSSL = true;
24         enableACME = true;
25       };
26
27       "making.awful.systems" = {
28         forceSSL = true;
29         enableACME = true;
30       };
31
32     };
33   };
34
35   security.acme = {
36     acceptTerms = true;
37     defaults.email = "self@awful.systems";
38   };
39
40   networking.firewall.allowedTCPPorts = [ 443 ];
41 }