]> Untitled Git - awful.systems.git/blob - pass/default.nix
Initial commit
[awful.systems.git] / pass / default.nix
1 { config, lib, pkgs, ... }:
2
3 {
4   users.extraUsers."_pass" = {
5     uid = 401;
6     isSystemUser = true;
7     home = "/home/_pass";
8     createHome = true;
9     group = "_pass";
10     shell = "${pkgs.git}/bin/git-shell";
11     openssh.authorizedKeys.keyFiles = [ ./pass_id_ed25519.pub ];
12   };
13
14   users.extraGroups."_pass" = { gid = 401; };
15 }