]> Untitled Git - lemmy.git/blobdiff - default.nix
add enable_federated_downvotes site option
[lemmy.git] / default.nix
index 6c261161c20dd7489628db1959368ce6d1a2267f..a3eeab1de9d8a29d632db173ec68dfdbb2cb5e82 100644 (file)
@@ -1,8 +1,8 @@
 { lib, stdenv, rustPlatform, fetchFromGitHub, openssl, postgresql, libiconv
-, Security, protobuf, rustfmt, nixosTests }:
+, Security, protobuf, rustfmt, nixosTests, lemmy-translations }:
 
 rustPlatform.buildRustPackage rec {
-  version = "0.18.2";
+  version = "0.18.4";
   pname = "lemmy-server";
 
   src = ./.;
@@ -11,7 +11,12 @@ rustPlatform.buildRustPackage rec {
     echo 'pub const VERSION: &str = "${version}";' > crates/utils/src/version.rs
   '';
 
-  cargoSha256 = "sha256-2HWz6gYRo4YkXQz4V5COY2vpCu/PD8kKxzDG21YjYbo=";
+  preBuild = ''
+    rm -rf crates/utils/translations
+    ln -sf ${lemmy-translations} crates/utils/translations
+  '';
+
+  cargoSha256 = "sha256-NPGKXA7S/pk13z9defahDuVAm3u444rLUGa+JhPxkfA=";
 
   buildInputs = [ postgresql ]
     ++ lib.optionals stdenv.isDarwin [ libiconv Security ];