]> Untitled Git - awful.systems.git/blobdiff - git/default.nix
swap lemmy deployment from these to more
[awful.systems.git] / git / default.nix
index 92667a5b9cc33709d6f8642661b04bc46ea002ba..a9eac6cfb19a3699fa1c3247fa4f0ad085205d1e 100644 (file)
@@ -2,12 +2,13 @@
 
 let
   new-repo = pkgs.writeShellScriptBin "new-repo" ''
-mkdir -p ${config.users.extraUsers.git.home}/repos/''${1}.git
-${pkgs.git}/bin/git init --bare ${config.users.extraUsers.git.home}/repos/''${1}.git/
-chown -R git:git ${config.users.extraUsers.git.home}/repos
-'';
-  in
-{
+    mkdir -p ${config.users.extraUsers.git.home}/repos/''${1}.git
+    ${pkgs.git}/bin/git init --bare ${config.users.extraUsers.git.home}/repos/''${1}.git/
+    chown -R git:git ${config.users.extraUsers.git.home}/repos
+  '';
+in {
+  imports = [ ../secrets/keys/git.nix ];
+
   users.extraUsers.git = {
     uid = 402;
     isSystemUser = true;
@@ -24,7 +25,7 @@ chown -R git:git ${config.users.extraUsers.git.home}/repos
     enable = true;
     location = "/git";
     group = "git";
-    virtualHost = "awful.systems";
+    #virtualHost = "awful.systems these.awful.systems these";
   };
 
   services.gitweb = {