]> Untitled Git - awful.systems.git/blobdiff - lemmy/server.nix
update lemmy to 0.18.1
[awful.systems.git] / lemmy / server.nix
index a76ce53bc7d522dddfaf849b42522ba86e67dd7c..890cc59df5dc5ba97c10edfacfb9d9e0597c28aa 100644 (file)
@@ -1,20 +1,9 @@
-{ lib
-, stdenv
-, rustPlatform
-, fetchFromGitHub
-, openssl
-, postgresql
-, libiconv
-, Security
-, protobuf
-, rustfmt
-, nixosTests
-}:
+{ lib, stdenv, rustPlatform, fetchFromGitHub, openssl, postgresql, libiconv
+, Security, protobuf, rustfmt, nixosTests }:
 let
   pinData = lib.importJSON ./pin.json;
   version = pinData.version;
-in
-rustPlatform.buildRustPackage rec {
+in rustPlatform.buildRustPackage rec {
   inherit version;
   pname = "lemmy-server";
 
@@ -26,6 +15,10 @@ rustPlatform.buildRustPackage rec {
     fetchSubmodules = true;
   };
 
+  preConfigure = ''
+    echo "pub const VERSION: &str = \"${version}\";" > "crates/utils/src/version.rs"
+  '';
+
   cargoSha256 = pinData.serverCargoSha256;
 
   buildInputs = [ postgresql ]