]> Untitled Git - awful.systems.git/blobdiff - lemmy/server.nix
update lemmy to 0.18.2
[awful.systems.git] / lemmy / server.nix
index 890cc59df5dc5ba97c10edfacfb9d9e0597c28aa..fa016593bb08605b618662a67dff7d7b024aa916 100644 (file)
@@ -2,7 +2,7 @@
 , Security, protobuf, rustfmt, nixosTests }:
 let
   pinData = lib.importJSON ./pin.json;
-  version = pinData.version;
+  version = pinData.serverVersion;
 in rustPlatform.buildRustPackage rec {
   inherit version;
   pname = "lemmy-server";
@@ -16,7 +16,7 @@ in rustPlatform.buildRustPackage rec {
   };
 
   preConfigure = ''
-    echo "pub const VERSION: &str = \"${version}\";" > "crates/utils/src/version.rs"
+    echo 'pub const VERSION: &str = "${version}";' > crates/utils/src/version.rs
   '';
 
   cargoSha256 = pinData.serverCargoSha256;
@@ -35,7 +35,7 @@ in rustPlatform.buildRustPackage rec {
   PROTOC_INCLUDE = "${protobuf}/include";
   nativeBuildInputs = [ protobuf rustfmt ];
 
-  passthru.updateScript = ./update.sh;
+  passthru.updateScript = ./update.py;
   passthru.tests.lemmy-server = nixosTests.lemmy;
 
   doCheck = false;