]> Untitled Git - awful.systems.git/blobdiff - lemmy/ui.nix
fix federation between lemmy and other activitypub services
[awful.systems.git] / lemmy / ui.nix
index 63551c3f22e9099eb54a52d3a09a03f462555bf3..d1d4ce6f679f099cd9d4b51b40e8f0256961774b 100644 (file)
@@ -23,7 +23,7 @@ let
   };
 
   name = "lemmy-ui";
-  version = pinData.version;
+  version = pinData.uiVersion;
 
   src = fetchFromGitHub {
     owner = "LemmyNet";
@@ -45,10 +45,6 @@ in mkYarnPackage {
     sha256 = pinData.uiYarnDepsSha256;
   };
 
-  postPatch = ''
-    echo "export const VERSION = '${version}';" > "src/shared/version.ts"
-  '';
-
   yarnPreBuild = ''
     export npm_config_nodedir=${nodejs}
   '';
@@ -58,6 +54,7 @@ in mkYarnPackage {
     export HOME=$PWD/yarn_home
 
     ln -sf $PWD/node_modules $PWD/deps/lemmy-ui/
+    echo 'export const VERSION = "${version}";' > $PWD/deps/lemmy-ui/src/shared/version.ts
 
     yarn --offline build:prod
   '';